finishing.com -- The Home Page of the Finishing Industry
A website for Serious Education, promoting Aloha,
& the most FUN smiley you can have in metal finishing

HomeFAQsSuggested
Books
Help
Wanteds
Advertise
on this site
FORUM
current topics
topic 60343

Brown mold (growth) in acid copper plating tank

60343
December 17, 2016

Q. Have a 4 gallon acid copper plating tank (just an basic acid/copper solution no additives) that has been unused for 3 months. I have noticed that there is a light brown/yellow mold? type growth on top of the solution. What is it and how do I get rid of it? Would an activated carbon filter help? Also how do I prevent it from recurring?
Thanks ahead of time for all your assistance!
frank

frank okral
hobbyist - middlesex New Jersey usa



This public forum has 60,000 threads. If you have a question in mind which seems off topic to this thread, you might prefer to Search the Site

ADD a Q or A to THIS thread START a NEW THREADView CURRENT TOPICS

Disclaimer: It's not possible to diagnose a finishing problem or the hazards of an operation via these pages. All information presented is for general reference and does not represent a professional opinion nor the policy of an author's employer. The internet is largely anonymous & unvetted; some names may be fictitious and some recommendations may be deliberately harmful.

  If you need a product/service, please check these Directories:

JobshopsCapital Equip. & Install'nChemicals & Consumables Consult'g, Train'g, SoftwareEnvironmental ComplianceTesting Svcs. & Devices


©1995-2018 finishing.com, Inc., Pine Beach, NJ   -   About finishing.com   -  Privacy Policy
How Google uses data when you visit this site.